LISTSERV mailing list manager LISTSERV 16.0

Help for LINUX-L Archives


LINUX-L Archives

LINUX-L Archives


LINUX-L@LISTS.UFL.EDU


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

LINUX-L Home

LINUX-L Home

LINUX-L  2010

LINUX-L 2010

Subject:

Re: Samba problems with UFAD

From:

Alexander M Thompson <[log in to unmask]>

Reply-To:

Platform Independent Linux List! <[log in to unmask]>

Date:

Tue, 20 Apr 2010 18:59:09 -0400

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (66 lines)

What does the net ads join abort message look like?

- Alex

Jon Akers wrote:
> What was upgraded via apt-get? If you don't have a nice handy list, 
> you might be able to tell by taking a quick gander at the creation 
> times of the files in /var/cache/apt/archives
>
> Brian Bartholomew wrote:
>> Main fileserver.  Runs Ubuntu 8.04 LTS.  Uptime 180 days.  Also runs
>> samba joined to UFAD; this is a custom version of samba in
>> /depot/samba-3.3.2, not the system samba.  Using the system Kerberos.
>>
>> Yesterday evening I did:
>>
>>     apt-get update
>>     apt-get dist-upgrade
>>     reboot
>>
>> This morning, samba is not working, as experienced from Windows clients.
>>
>> The relevant error message seems to be in 
>> /depot/samba-3.3.2/var/log.wb-UFAD
>>
>> [2010/04/20 17:28:43,  2] 
>> libsmb/cliconnect.c:cli_session_setup_kerberos(617)
>>   Doing kerberos session setup
>> [2010/04/20 17:28:43,  1] libsmb/clikrb5.c:ads_krb5_mk_req(686)
>>   ads_krb5_mk_req: krb5_get_credentials failed for UFDC04$@UFAD 
>> (Cannot resolve network address for KDC in requested realm)
>> [2010/04/20 17:28:43,  1] 
>> libsmb/cliconnect.c:cli_session_setup_kerberos(624)
>>   cli_session_setup_kerberos: spnego_gen_negTokenTarg failed: Cannot 
>> resolve network address for KDC in requested realm
>>
>> These things seem to work:
>>
>>     kinit [log in to unmask]
>>     klist
>>     /depot/samba-3.3.2/bin/net ads join -U "CLAS-ADM-BB"
>>
>> The symptoms resemble this bug, but why would I suddenly start seeing 
>> them?
>>
>>     https://bugs.launchpad.net/ubuntu/+source/samba/+bug/553342
>>
>> Things I've tried on the two versions:
>>
>>     many restarts in various orders
>>     debugging flags -d 1, -d 10, -d 99
>>
>>     # To reset state and logs between restarts
>>     find var -type f -print | xargs rm
>>
>>     winbind separator = \\
>>     winbind separator = \
>>
>>     recompile samba 3.3.2: no change
>>
>>     install samba 3.5.2: Aborts at the net ads join
>>
>> Thoughts?
>>                             Brian
>>   
>

Top of Message | Previous Page | Permalink

Advanced Options


Options

Log In

Log In

Get Password

Get Password


Search Archives

Search Archives


Subscribe or Unsubscribe

Subscribe or Unsubscribe


Archives

2022
2021
2020
2019
2018
2017
2016
2015
2014
2013
2012
2011
2010
2009
2008
2007
2006
2005
2004
2003
2002
2001
2000
1999
1998
1997

ATOM RSS1 RSS2



LISTS.UFL.EDU

CataList Email List Search Powered by the LISTSERV Email List Manager