I have a HP machine running RHES4 here which has/seems to claim
its controller is a compaq smart array (during boot time it identifies
itself as hp smart array 6i, but who am I to disagree?). Connected to it
are two hard drives. For some reason, one of its hard drives died on
Sunday.  It worked for a day and then when we tried to boot it, it would
stop at at very limited grub screen. I then booted it off the centos
liveCD. The hardware browser the disk is mounted at /dev/cciss/c0d0. The
hardware browser not only finds it but also shows me the different
partitions defined in it. I would put its output here but I do not know
the equivalent command.  So, let me show what I know so far:

[root@netips31 ~]# mke2fs -n /dev/cciss/c0d0
mke2fs 1.35 (28-Feb-2004)
Filesystem label=

OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
17924096 inodes, 35841780 blocks
1792089 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=37748736
1094 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632,
        2654208, 4096000, 7962624, 11239424, 20480000, 23887872

[root@netips31 ~]# e2fsck -b 819200 /dev/cciss/c0d0
e2fsck 1.35 (28-Feb-2004)
e2fsck: Bad magic number in super-block while trying to open

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

[root@netips31 ~]# dmesg | grep ccis
cciss: Device 0x46 has been found at bus 2 dev 1 func 0
cciss: using DAC cycles
 cciss/c0d0: unknown partition table
VFS: Can't find a valid FAT filesystem on dev cciss/c0d0.
[root@netips31 ~]#

Now, inside dev/cciss is only one file: c0d0. So, I do not see how I would
be abl to mount those volumes. Where do I go from here?