Print

Print


Setup: Ubuntu 7.04, Dell D620, nVidia NVS 110

The only convenient way that I found to correct my resolution problem turned out to be very simple:
edit xorg.conf with output from command gtf, where resolution arguments are manually provided.

$ gtf 1440 900 60

  # 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
  Modeline "1440x900_60.00"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync

update monitor section in /etc/X11/xorg.conf

Scott


2007/7/20, Ben Preston <[log in to unmask]>:
On 7/20/07, Ed Hennis <[log in to unmask]> wrote:
> On Thu, 19 Jul 2007, 2:40pm (-0400), Bill Schwab wrote:
>
> > Enter google, and I found references to a bug and manual edits to the
> > X11 config, in particular adding refresh rates.  That worked, but I am
> > wondering whether there is a better solution?  Might the first monitor
> > have triggered the problem?
>
> I'm not sure not Ubuntu-specific this solution is, but when I upgraded to
> a widescreen monitor I tracked down:
>
> sudo dpkg-reconfigure xserver-xorg
>
> from the command line (I think it worked better when done from a text
> terminal and not within X).  It autodetected some things, but required me
> to enable certain resolutions.  It was easier than messing with xorg.conf
> and may work for you, too.
>
> For further reference: http://ubuntuforums.org/search.php and search for
> "dpkg resolution"
>

You could also try booting from a live CD and copying the xorg.conf
file, assuming the resolution is correct in the live session.

--

Ben